Aller au contenu

Impla007

Utilisateurs inscrits
  • Compteur de contenus

    66
  • Inscription

  • Dernière visite

Réputation sur la communauté

0 bof

À propos de Impla007

  • Rang
    Interréssé

Converted

  • habite à
    06
  1. Impla007

    Image toujours en N/B avec Prism

    Non pas vraiment . J avais un peu cherché à l époque mais j avais assez rapidement utilisé dcraw pour les transformer en tif . Je pense Qu aujourd hui tout le monde utilise dcraw et plus particulièrement libraw pour implémenter les lib de décodage dans du soft . Par contre, je crois me souvenir que libraw n exploite pas toute la dynamique des 14 bits de prévus par Sony . Je crois aussi me souvenir que seuls les plugin Sony (payants) exploitent toute la dynamique possible. Après, libraw marche bien .
  2. Impla007

    Image toujours en N/B avec Prism

    Michel, Sony ne donne pas accès à l image raw lors de la commande prise de vue. C est uniquement l image jpeg qui est renvoyée par l a7s vers le driver . L image raw est elle presente sur la carte SD dans l a7s . Cette image jpeg est cependant représentative (avec les perturbations liées au jpeg) de l image raw. Cette image jpeg est utilisable pour l astrometrie, le focus le réglage du temps de pose ect. Pour les traitements ultérieurs, c est malheureusement les images raw au format Sony présents sur la carte mémoire Qu il faut utiliser . Je pense que Sony a introduit volontairement cette limitation car le sdk est fait pour être utilisé avec des smartphones et cela aurait obligé Sony à à diffuser largement son format raw avec ses bibliothèques de lecture . Afin de permettre de faire du remote avec l a7s , et pour éviter d avoir à faire la manip physique de retirer la carte et de la mettre dans l ordi, j ai intégré dans le driver un mode de transfert des images raw de la carte vers un répertoire. Mais cela doit se faire dans un autre mode que le mode que le mode de prise de vues. C est d autant plus contrariant car l accès à l image raw est néanmoins possible au moment du shoot mais, en passant par un sdk non supporté par Sony et qui nécessite de bricoler un peu son a7s .... Je n ai pas voulu m embarquer dans ce type d acrobaties pour ce driver et je suis resté pile poil avec ce que propose l interface officielle .
  3. Impla007

    Image toujours en N/B avec Prism

    Michel, Sympa d avoir fait un soft au dessus du driver, j adore . J imagine que tu as une bonne raison de vouloir une image couleur .. je ne me souviens plus de ce que j ai fait ... et comment ... je suis quasi sûr que l image couleur n est pas une image 3 dimensions r,v,b mais une image x,y avec une matrice de bayer , je me souviens avoir “bayerisee “ l image jpeg retournée par l A7S pour la rendre compatible avec ascom . Mais il n est pas impossible que j ai oublié de renseigner une variable, ATP s en accommode, pas prism ou inversement ? Faut que je regarde de près . Je pense que le toogle image couleur du driver n est pas pris en compte (tu as regardé dans le log du driver Il devrait y avoir un message du style image couleur ou nb sélectionnée ? ) un bug quelque part certainement , faut que je fouille . Pour l instant je n ai pas accès à un éditeur et un debugger (j ai juste un tel) mais dès que je rentre, je regarde . pour ton info, dans ton directory /tmp ou user/tmp (me souviens plus du nom sous Windows) tu dois avoir une image jpeg qui s appelle temp qui représente la dernière image transférée par l a7s vers le driver . Si ça peux t aider en attendant, c est bien pratique pour comprendre ce qui se passe. Si cette image temp est une jpeg en couleur et que tu as du nb en sortie de driver, c est Qu il y a un truc qui merdouille dans le driver . (Désolé... je vais corriger) Georges
  4. Impla007

    Image toujours en N/B avec Prism

    Bonjour, Le sdk pour l a7s et l ensemble des apn Sony est dispo ici : https://developer.sony.com/develop/cameras/ Ce sont des commandes json qui sont relativement simple à mettre en œuvre . Il n y a pas de difficulté particulière , le sdk est « assez» exact et précis peut être une ou deux coquilles ou omission mais qui ont peut être été corrigées depuis . La principale difficulté avec l a7s, c est que le boîtier fait un peu ce Qu il veut . On envoi une commande , on peut être certain que le boîtier va va répondre mais quand ? La difficulté derrière ce fonctionnement ce sont les diffèrent locks et timeout mis en place par l ascom . J ai bien galèré avec ce problème et surtout avec la façon dont les différents logiciels hôte gèrent les exceptions . Ne pas hésiter à me contacter en mp si besoin .
  5. Impla007

    Image toujours en N/B avec Prism

    Bonjour, je viens de vérifier et effectivement lorsque l on est avec prism les images affichées dans la fenêtre de prism sont en n/b . Après, c est uniquement dans la fenêtre de visualisation. Les images enregistrées par l a7s sur la carte mémoire sont bien en couleur . A priori , je ne pense pas que cela vienne de prism et je suis quasi sûr que cela ne vient pas du protocole de transfert d images (sinon ça planterait) . Lorsque j ai développé le driver, je n avais pas de licence prism et donc je n ai pas particulièrement insisté dans le débug avec prism . Je n ai pas les moyens en ce moment de regarder ce problème mais je regarderai en septembre . C est bizarre d autant plus que cela fonctionne avec maximdl( je viens de vérifier) . J ai eu un bug similaire avec prism où le toggle relatif à la taille de l image dans le driver n était pas toujours pris en compte . Des fois ça marchait, des fois cela de marchait et as . J avais dû y apporter une modification, sans réellement bien comprendre ce qui s était passé , la case était bien cochée/décochée mais le driver ne recevait pas l info de Windows. C est comme si il y avait un conflit entre le gestionnaire de fenêtre de prism et celui de visual studio qui a servi à faire le driver. C est peut être le même problème pour le Toogle de la visualisation en couleur . C est comme si le driver ne recevait pas l info ou n était pas prêt à la recevoir . Donc, sauf analyse plus détaillée , le pb vient de la fenêtre du driver qui possède la case à cocher nb/couleur mais plutôt avec prism car avec Maxim ou ATP ça marche ... pourquoi ??? Je regarderai plus en détails . On doit aussi pouvoir récupérer le log pour voir si le driver a bien reçu l info . Georges
  6. Thanks you to have investigate this bug. I Will fix it in the next release . I never saw it because I am always in black and white mode.
  7. This version V1 is exactly the same as the V074 you should have. The V1 is not yet ready to fill. The V074 is here https://goo.gl/QnDtnm
  8. Thank you very much for your help! But I have removed the black and white option. The FIT file that was shot could not be colored. I just checked and it works here May be try to exit maximdl, turnon/off the a7s and try again but with uncheking the b/w box at the first connexion of the driver
  9. Hello , you hav to go to the a7s ascom parameter and to uncheck the black and white box. You Will then be able to get a bayer color image Hope it helps Georges
  10. When the remote control app is running in the A7S, press the menu button and in the parameter of the app, goto image quality and set it to raw+jpeg... The is a pitfall of the A7S software, when you set the image quality on the main setting of the A7S, it does not set the quality for the remote app.... Hope it helps.. Georges
  11. Bonjour, Comme dit frédo, cela ne marche pas pour autre chose que l'A7S . J'ai volontairement intégré au driver une reconnaissance du type d'APN et un message d'erreur est envoyé a l'utilisateur si ce n'est pas un A7S car je n'ai pas paramétré les différentes tailles images et autres spécificités (iso/vitesse/liveview...) pour ces APN. Je travaille actuellement à une version plus facilement customisable . Georges
  12. Salut Joseph, Pour le point 1) J'ai un peu amélioré la taille de la fenêtre du liveview mais pas sur que ça suffise pour voir toujours les ascenseurs surtout avec des PC avec faible résolution. Ca devrait marcher en résolution 1300*800 mais en dessous, tu risques de perdre les ascenseurs. En 800*600 ca marche pas, j'ai essayé... Pour le point 2), je ne pige pas ce que tu veux que cela fasse ? Sinon, dans le driver en plus du fenêtrage, j'ai fait un mode Bin2, addition simple, c'est pratique (Bien sur à utiliser en mode N&B sinon, ça n'a pas de sens) Dés qu'il fera un peu beau, je vais essayer cette version V0.72 sur le ciel et si ca marche, je diffuse.
  13. Attends que je l ai terminée avant d annoncer ... je ne l ai pas générée encore )) Pfff 1366 x 768, t es resté à l an pépin ...
  14. Salut Bruno et bravo de faire bouger les devs sous linux ..... J'ai effectivement essayé d'utiliser indi avec l'A7S et malheureusement... je n'ai pas réussi a changer la vitesse d'obturation.. Pour réaliser le driver ascom, j'ai utilisé le SDK mis en place par Sony. ici https://developer.sony.com/file/download/sony-camera-remote-api-beta-sdk/ Ils ont fait trés bien le boulot et parfaitement documenté les différents appels aux commandes json Pour récupérer la liste des différents shutterspeed j'ai utilisé la commande json "getSupportedShutterSpeed" { "method": "getSupportedShutterSpeed", "params": [], "id": 1, "version": "1.0" } Elle fonctionne avec cette syntaxe sans problème. Cependant, comme tu le sais certainement, sony a mis en place un serveur spécifique dans l'A7S pour interpréter les commandes et contrôler le boitier et, je doute fort que le serveur qui utilise le wifi comme support soit le même que celui qui utilise l'USB comme support. Le sdk auquel je fais référence est celui qui utilise le wifi comme support. Je ne me suis pas penché sur celui utilisant l'USB. Il est possible que ce soit similaire mais....avec le dev logiciel, on peut facilement confier le dev de l'USB a une équipe et le wifi a une autre.... Par contre, ce que j'ai remarqué c'est que bien que le SDK de sony soit trés complet, des fois il y a quelques "coquilles", il manque une virgule ou un point ou un crochet qui fait que la commande ne passe pas. J'en ai fait plusieurs fois l'expérience. Par contre, ce n'est pas trés difficile a trouver et a corriger. Je suis assez étonné que ce truc ne fonctionne pas en USB. C'est assez basique. Si tu sais ou sont les sources de libgphoto2, j'irais jeter un oeil. Georges
  15. Bonjour, Il pleut... alors, j'ai développé le fenetrage dans le driver..ce sera la version V0.72 Elle tourne chez moi. Le fenetrage est reconnu et controlé par les principaux soft (maxim, APT, SGP, PRISM...). Par contre, il ne faut pas penser que le fenetrage va réduire le temps de transfert d'image car ce n'est pas l'A7S qui fait le fenetrage mais le driver. Donc, le temps de transfert reste identique. Ca semble fonctionner avec PRISM, y compris dans son utilisation du mode de focalisation. Avant de mettre en boite et finaliser la version, pour le probleme de liveview qui n'affiche pas les ascenceurs, j'aimerai bien savoir quelle est la résolution d'écran que vous utilisez et qui pose probleme ? J'ai aussi intégré quelques autres bricoles dont la possibilité l'enregistrement de vidéos dans l'A7S à partir du mode liveview et aussi la possibilité d'envoyer des enregistrements de séquences d'images a partir du liveview. Si il continue a pleuvoir... et maintenant que j'ai remis les mains dans le cambouis, je vais peut être en profiter pour développer un mode de binning aussi. Si vous avez des demandes,.. c'est maintenant... Georges
×
×
  • Créer...

Information importante

Conditions générales