Aller au contenu
Amortalis

Nova Sigma CCD Win 10 64 bit version

Messages recommandés

Hello there

First of all sorry about the english topic.

I don't believe that some of you can remember me but I will give a try.

Once upon a time it was an yahoo group dedicated to the Nova Sigma CCD cameras, yeap thats me, it was my group.

Unfortunately there is no Astroelektronik Fischer anymore so a few years later I shoot down also the forum.

Meanwhile I moved to a QHY9M camera but I still have the trusted Nova (based on the Kodak 1602E sensor).

So Windows moved on 64 bit, more RAM to have, plenty of space on our HDDs but what about our CCDs? Nope, no drivers, no nothing, zipp, null. We have nothing.

But there are ways to do it (hopefully).

Attached a technical test, just dont jump too high, just managed to get it recognised by Windows, no image test yet.

If you can please send me the drivers that you have for your Sigma camera, I try to create an unified driver: for Nova, Guider, Sigma and Sigma 2.



Take care

Emil


P.S. I have seen a post saying something about an ASCOM driver for Sigma, some news about that?



Screenhoot

https://dl.dropboxusercontent.com/u/67088064/Nova%20CCD%20unter%20Win%2010%2064%20bit.JPG

Modifié par Invité

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai longtemps espéré un drivers ascom pour cette ccd....

mais l'auteur a arrêté toute activité avant d'avoir développé ce drivers



j'ai 4 élements :

1. les drivers d'origine ScPro2 V603DLL32REG20 : https://drive.google.com/open?id=0B5V-j1WknnO1Sk1hcDhDVmtpYm8

2. le drivers 32 et 64 bit développé par Emmanuel Rischt : https://drive.google.com/open?id=0B5V-j1WknnO1NlR6SXZON0lyYms

3. le drivers maxim DL : https://drive.google.com/open?id=0B5V-j1WknnO1MlZzZGlDdF8yY0E


4. et surtout j'ai le code source, commenté en allemand : https://drive.google.com/open?id=0B5V-j1WknnO1STNFOHNEMzZoamV3UjV0ZmdvLWdQbTFydUZ3

Partager ce message


Lien à poster
Partager sur d’autres sites

@ frédogoto

That is good, thanks for sharing, the Rischt drivers will help me the most I guess. Anyway Im in contact with FTDI about this one, if I manage to do something I will post it here.


Take care

Emil

Partager ce message


Lien à poster
Partager sur d’autres sites

Small update


https://dl.dropboxusercontent.com/u/67088064/Nova%20avec%20MaximDL%206%20et%20Win%2010%2064%20bit.JPG


To be clear, Nova is a camera developed before Sigma, is, as far as I know, based on the Audine project (but it can be that I am wrong).

So first test under Win 10 Home 64 bit version and Nova, cooling is displaying correct values, also the shutter works. So far so good.


I will post here so far I advance. Wish me luck because I really need it.


Emil

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,


Frédéric un grand merci pour le partage, cela me servira sans doute un jour aussi pour ma sigma1603ME !

Emil m’avait contacté par mail directement, je ne savais pas que tu avais ces informations…

Finalement il a trouvé une personne qui a pu l’aider, c’est super :)


Là où je ne comprends pas, qu’elle est la suite ?

De faire fonctionner la sigma via ascom ?



Google Traduction :

Hello,


Frédéric a big thank you for sharing, this will serve me one day perhaps also for my sigma1603ME!

Emil had contacted me by email directly, I did not know you had this information ...

Eventually he found someone who was able to help, that's great :)


Where I do not understand, it is the result?

To operate the sigma via ascom?

Partager ce message


Lien à poster
Partager sur d’autres sites

en tout cas c'est ce que j'espérais, mais j'ai surtout l'impression qu'on ne parle pas de la même chose... :(


Emil souhaite développer des drivers 64b pour une ancienne camera..., plus ancienne encore que les sigma...

mais pour nos sigma pour le moment c'est le desert : elles sont limité a maximdl

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah ok j'ai un peu de mal avec les langues :(

Tu as encore ta Sigma ? Je pensais que tu ne l'avais plus, autant pour moi !


Ah ok I have a little trouble with the language :(

You still have your Sigma? I thought you had no longer, as much for me!

Partager ce message


Lien à poster
Partager sur d’autres sites

My French knowledge is really bad but I guess I got the message. In the following days I will test the camera with SCPRO and AstroArt. I want to see if the camera can be controlled by other software packages.

My idea is to get a unified driver for the entire product range starting from Nova and going up to Sigma 2.

For an Ascom driver I will try to get aboard a friend of mine that has some experience in this area. I know that he succeeded in creating an ascom driver and also an driver for Linux.

UPDATE:

Until now I created the inf file for Nova and Sigma cameras and have the confirmation for Nova. For getting the camera to work under Win 10 64 I had to restart win with the option "allow unsigned drivers instalation" activated. The how-to information I got it from FTDI directly. I will post today a link to this file but Noel also had this file from me, if he has time he can do it too.

Next step from my side is to get again in touch with FTDI and see if I get a way to have the drivers signed by them.

Nova is normally using the ft222xxx.dll file but with my modification is using the latest ftdi drivers using a diferent driver. The same goes for the first Sigma camera but I don't have a sigma so if someone having a sigma camera is willing to give a try please tell me.

From my point of view having to restart the pc to accept unsigned drivers is a little bit better as having nothing.


All the best

Emil

Partager ce message


Lien à poster
Partager sur d’autres sites
(...)

My idea is to get a unified driver for the entire product range starting from Nova and going up to Sigma 2.

très intéressant. On attend la suite :) :)

For an Ascom driver I will try to get aboard a friend of mine that has some experience in this area. I know that he succeeded in creating an ascom driver and also an driver for Linux.

ouhaaa ça c'est de la bonne nouvelle. il a mis son drivers quelques part qu'on puisse le télécharger et le tester ?


 

Until now I created the inf file for Nova and Sigma cameras and have the confirmation for Nova. For getting the camera to work under Win 10 64 I had to restart win with the option "allow unsigned drivers instalation" activated. The how-to information I got it from FTDI directly. I will post today a link to this file but Noel also had this file from me, if he has time he can do it too.

nice :)

Next step from my side is to get again in touch with FTDI and see if I get a way to have the drivers signed by them.

Nova is normally using the ft222xxx.dll file but with my modification is using the latest ftdi drivers using a diferent driver. The same goes for the first Sigma camera but I don't have a sigma so if someone having a sigma camera is willing to give a try please tell me.

yes , i would like to test :)

From my point of view having to restart the pc to accept unsigned drivers is a little bit better as having nothing.

assurément :}}

Partager ce message


Lien à poster
Partager sur d’autres sites

https://dl.dropboxusercontent.com/u/67088064/Nova%20Sigma%20drivers.zip


Driver is designed for Nova and Sigma cameras


For Nova VID and PID description is

VID_0403&PID_e168



For Sigma

VID_0403&PID_e169


ATTENTION: Is not to be used with Sigma 2 cameras. They have different VID and PID numbers and I will implement them this week.


So if someone has access to a Sigma camera (those with up to KAF 3200 senzor) please give a try, especially for the 1603ME model.

Im not sure if the VID_0403&PID_e169 describes the Sigma 1603ME model or is general for all Sigma cameras.


Please report back

Partager ce message


Lien à poster
Partager sur d’autres sites

j'essaierai de tester ça pour la sigma1603ME mais pas avant ce weekend.

Déjà merci d'avance pour ce travail ! :)


I will try to test it for Sigma 1603ME but not before this weekend.

Already thank you in advance for this job! :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Amortalis, when i install ma Sigma2 on W10 with riescht drivers, it work fine. i see on my device manager the serial com sigma on unknow device but the ccd work fine without this. But i supposed this is better to install this drivers so i did it...

what FTDI does ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Not sure about that but let me just guess. The unknown device is not defined, it should assign to it a com port.

Try to update the drivers by point the installer assistent to the driver pack and see what is happening.

I had the same effect when I firstly managed to start the Nova under Win 10. The Nova was recognized but I had also one unknown device listed. By updating the driver instead of unknown device I had a com port listed.

Can you post a screen shot of the device from device manager? Should show no driver loaded or similar.


Take care

Emil

Partager ce message


Lien à poster
Partager sur d’autres sites

Update:

I have used the drivers that I modified on an Win 7 Ultimate 64 bit version. Windows pop out the message that the driver is not digitally signed and asks if it should install anyway the drivers. A few minutes later in device manager the Nova is showed as working properly and a second device appears as "Nova on unknown device" right click on it and select "install drivers" point the installer to my drivers and some time later appears a com port and Nova is showed as "Nova on Com 15". Functionality tested till now only with the controller box, without CCD head but Maxim connects without errors. I will test in the following hour the functionality of the CCD head under Maxim and Astroart (version 5 and 6).

WARNING: the Installation in not yet possible under normal circumstances for Win 10 (in Win 10 the installation HAS to be done under a special mode reachable only with an restart).


Take care

Emil

Partager ce message


Lien à poster
Partager sur d’autres sites

Good news :)

I just installed your driver , I also had an unknown device and makes updating the driver.

I had after Sigma com3 harbor :)


Then I wanted to install SCpro but then it did not work :(

But I have it every time!


I do not think by testing against Astroart already installed on the PC , I think it would work ... I already had the problem with Scpro and it worked with MaximDL and Astroart .


I test at the latest tomorrow morning )


Bonne nouvelle :)

Je viens d'installer ton driver, j'ai également eu périphérique inconnu et fait une remise à jour du pilote.

J'ai eu après Sigma en port com3 :)


Ensuite j'ai voulu installer SCpro mais là cela n'a pas fonctionner :(

Mais j'ai cela à chaque fois !


Je n'ai par contre pas penser à tester Astroart déjà installer sur le PC, je pense qu'il marcherait...J'ai déjà eu le problème avec Scpro et cela fonctionnait avec maximdl et astroart.


Je teste au plus tard demain matin ;)


Christophe

Partager ce message


Lien à poster
Partager sur d’autres sites

UPDATE

On every software tested: Maxim 5 and 6, AstroArt 5 and 6 I have black image. Pixel value 0, perfect darks.

Im working on it, it can be that the driver for Nova (the maxim and Astroart drivers) are not getting correctly the image from camera.

Partager ce message


Lien à poster
Partager sur d’autres sites

So after installing the drivers of Amortalis via the file manager, I confirm that the Sigma1603ME works seamlessly with Astroart!

It's good news :)


By cons can not operate Scpro ...

I always have a message it can not find the USB drivers and starts in demo mode.

I imagine it would change the way you install the software.

For it seems to install the original drivers (32bit) along scpro.

These drivers do not work with 64bit, as we know.

And installation of scpro does not know your driver ...


But if one has already MaximDL Astroart and that can drive the Sigma1603Me with W7 64bit is already good news :)

Thank you Amortalis and Fredéric!


Ascom remains a driver? To use the Nova and Sigma with any software?



Après donc installation des drivers de Amortalis via le gestionnaire de fichiers, je confirme que la Sigma1603ME fonctionne sans problème avec Astroart !

C'est une bonne nouvelle :)


Par contre impossible de faire fonctionner Scpro...

J'ai toujours un message qu'il ne trouve pas les drivers USB et démarre en mode démo.

J'imagine qu'il faudrait modifier la manière d'installer le logiciel.

Car il semble installer les drivers d'origine (32bits) en même temps que scpro.

Ces drivers ne fonctionnent pas avec 64bits, on le sait.

Et l'installation de scpro ne connait pas ton driver...


Mais si on n'a déjà Maximdl et Astroart qui peuvent piloter la Sigma1603Me avec W7 64bits c'est déjà une bonne nouvelle :)

Merci Amortalis et Fredéric !


reste un pilote Ascom ? Pour pouvoir utiliser les Nova et Sigma avec tout les logiciels ?

Partager ce message


Lien à poster
Partager sur d’autres sites

@ Christophe

SCPro will NOT run on Win7, I tested with the 32 bit version.... I guess I cant help there as I have no idea about the coding in SCPro but I have some file called SCPro update for Windows Vista (I can upload it here over dropbox if requested).

Seccondary I dont believe that Thomas will grand us access to the source code for SCPro and in that area I dont have any experience.


Thanks for reporting back. Im glad that it worked.

Regarding the black screen that I have with Nova, I guess I have found something (is not applying to your cameras so long the camera is not using the D2XX (DLL).


If an extra COM port is not available after installing the latest CDM driver, connect the USB device and open Control Panel > System > Device Manager. Right click on USB Serial Converter under USB Controllers and select Properties, then the Advanced tab. Check the box marked "Load VCP", then click OK. Unplug and re-plug the USB device, and the COM port will be added. This method is also used to change the driver mode from VCP to D2XX (DLL).


About ASCOM, nope is not dead, Im working on it, so far I have something I will post it here. Is acctually my main target to have an ASCOM driver for our cameras.


Take care

Emil

Partager ce message


Lien à poster
Partager sur d’autres sites

Indeed on Win 7 it ​​does not work and I suspected a bit but I tried ;)

As long as it works with MaximDL and Astroart is already beautiful! :)


I have the Vista update, now the PC for astronomy works with Vista.


Good luck for your Nova :)


Thank you for all,

Christophe


Fredogoto , you have the source code Scpro !

Great :)

Finally I do anything with ;)

We'll see if Emil can get there, but good is this important ?

If you already have other software that works with CCD ...

Partager ce message


Lien à poster
Partager sur d’autres sites

I have image on Nova!!!

The cooling finger (the metal part between peltier and CCD) have pushed out the CCD from socket. Now it works again.


Take care

Emil

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...

Information importante

Conditions générales