Aller au contenu

Raspberry P I ... I m'enerve


mg95
 Share

Messages recommandés

  • Avexiens

La conf un raspberry pi4 alimenté par sa propre batterie sous Raspberry Pi OS et opéré via VNC en Wifi.

Je tiens au Wifi et VNC et comme toute l'installation d'Ekos, PHD2 et ASTAP c'est fait de cette manière j'en ai déduit raisonnablement que le Wifi fonctionnait.

La nuit tombe, les premiers réglages de mise au point et d'astrométrie sont très laborieux au point que je repasse sur une plateforme Windows pour les initialiser.

Je continue à bricoler sur le RPi, puis je le laisse tranquille pendant une heure et quand je reviens VNC a perdu la connexion.

Je débranche le RPi (pas bien) pour le redémarrer et là plus moyen de s'y connecter en Wifi, j'ai beau scanner tout le sous réseau je ne le retrouve pas. Je laisse tomber.

Naturellement ce matin la même config fonctionne.

 

 

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens

Est-ce qu'il ne se serait pas mis en mode hotspot ? Genre il ne détecte pas ton wifi pour une raison ou une autre et passe en hotspot...

Ou alors problème purement réseau: DHCP / adressage...

Au début j'avais souvent des soucis de ce genre surtout avant d'avoir mon répéteur - il perdait le réseau, faisait n'importe quoi, ou bien ma box était mal configurée (désormais je lui ai attribué une IP fixe no mater what)... Heureusement j'ai un petit moniteur HDMI sur batteries - on en trouve des pas très cher avec alim USB qui font le job, genre 50/60 euros - que je peux brancher dessus ainsi qu'un dongle clavier/souris sans fil quand je n'ai aucun accès via réseau. Mais depuis que j'ai mon répéteur et que j'ai fini par configurer une ip fixe je n'en n'ai plus eu besoin.

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens
Citation

Est-ce qu'il ne se serait pas mis en mode hotspot ?

Je suis parti de l'OS de base, pas d'une image pret construite. Je crois qu'il faut configurer le mode hotspot pour qu'il s'active, à minima donner un SSID et password.

Mais effectivement il me semble que le RPi peut "disabler" tout seul des réseaux Wifi.

Maintenant pourquoi perd il le Wifi ?

J'ai déjà fait tourner la même config avec un portable W10 à la place du RPi et je n'ai jamais eu de problème Wifi.

Le pilotage et le guidage de la monture se fait par Wifi, donc en cas de perte je m'en serai aperçu.

Merci pour ton aide.

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens

Peut-être que la puce wifi de ton portable était de meilleurs qualité que celle du RPI et perdait moins le signal? 

Je pense que quand ça arrive il faut que tu te connecte en direct dessus (écran+clavier/souris) pour regarder sur quel réseau il est, quelle IP, etc... (commande ifconfig) Il faut aussi regarder dans les configs de ton routeur wifi s'il est bien visible, si le DHCP est activé, si tu n'as pas un filtre sur adresses MAC, vérifier aussi si le RPI est bien configuré pour utiliser le DHCP ou s'il se donne une IP lui-même, si les configs d'IP de sous-réseau / passerelle / DNS sont bonnes, etc... J'ai galéré pas mal avec ces trucs là au moment de l'installation de mon répéteur par exemple.

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens

Personnellement il n'y a qu'une seule fois où il a perdu le wifi dans le jardin car j'ai mis la monture dans un coin où je ne vais jamais... 

Depuis j'ai fait un test tout simple, tu prend ton PC portable et tu le branches avec le PI avec un bête cable ethernet et le tour est joué... tu te retrouves en réseau avec le PI (il faut attendre quelques minutes que le réseau monte), tu relances VNC  et tu regardes ce qui se passe avec le wifi du PI.

Esayye ça calmement au chaud en journée.... moi aussi je n'ai jamais emmené le PI en sortie et je voulais m'assurer qu'il y avait bien un moyen de prendre la main à coup sûr.

Courage!

 

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens
Citation

tu le branches avec le PI avec un bête cable ethernet

Faut pas un câble croisé ?

Garder la main sur le RPi chez moi c'est pas un problème, mais la panne a l'air aléatoire.

Citation

emmené le PI en sortie

Ça se passerait peut être mieux !

Je viens de penser à une chose, le RPi connait et est habilité sur d'autres Wifi chez moi, il a peut être basculé sur un autre réseau.

Connaissez vous la config pour le verrouiller sur un Wifi, ça m’embêterai de devoir désactiver les autres 😞

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens
il y a 30 minutes, mg95 a dit :

Faut pas un câble croisé ?

Non, ça fait des lustres qu'on n'a plus besoin de câble croisé dans ce genre de réseau point à point PC, je sais même pas s'il s'en vend encore - tu es de la vieille école 🙂

il y a 31 minutes, mg95 a dit :

Connaissez vous la config pour le verrouiller sur un Wifi, ça m’embêterai de devoir désactiver les autres 😞

Je connais pas non... En revanche une idée, du moins si sur tous ces wifi il peut accéder à internet, serait d'utiliser TeamViewer à la place de VNC en ouvrant un compte gratuit chez eux. Il permet d'enregistrer ta machine et d'être notifié sur ton client/pc principal quand elle est en ligne, quelque soit le réseau - et du coup il récupère directement la bonne IP pour la connexion.

(Et sinon, développer un petit script qui envoi régulièrement un petit ping vers l'adresse de ton PC principal en donnant l'info sur son IP, et un autre côté PC à l'écoute de ce ping - mais là ça devient de la bidouille je suis même pas certains que je saurais encore faire ça aujourd'hui :-))

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens
Citation

tu es de la vieille école 🙂

Hé oui ! J'ai connu l'info sans IP, la stack n’était même pas dans le noyau de base (Unix), il fallait le recompiler.

On peut mettre des priorité dans wpa-supplicant ça pourrait régler mon problème.

Je m'intéressais surtout à Ekos pour le séquenceur, mais depuis que j'ai découvert NINA, ça devient moins urgent.

Et si j'en crois WhatSapp il y a d'autres soucis 😞.

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens
il y a une heure, mg95 a dit :

Et si j'en crois WhatSapp il y a d'autres soucis 😞.

Ouaip, il semble que ce soit moins sec que Nina, mais ça évolue et s'améliore au fil du temps. Moi ce qui m'intéresse surtout c'est d'avoir ce RPI collé à ma monture de sorte qu'il n'y ai plus de câbles partout et plus de PC portable prenant l'humidité pendant mes nuits de shooting. C'est pour ça que je persévère 🙂 

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens

Dans ce cas il y a la solution de ne mettre qu'INDI sur le RPi et de faire tourner Kstar/Ekos sur un PC.

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens
il y a une heure, mg95 a dit :

Dans ce cas il y a la solution de ne mettre qu'INDI sur le RPi et de faire tourner Kstar/Ekos sur un PC.

D'après ce que j'ai pu voir des discussion à droite à gauche sur ce forum c'est encore plus compliqué comme ça 😄

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens

@peppuccio J'ai mis un message sur le forum Indi concernant mon souci qui ressemblait au tien de l'autre jour (arrêt des prises juste après un méridien flip réussi) : https://www.indilib.org/forum/ekos/9356-phd-guiding-settling-error-after-meridien-flip.html

Pas encore de réponse, mais je pense que ça peut être évité en mettant une valeur ici plutôt que zéro comme c'était par défaut chez moi:

image.png

Je suis sous PHD mais ya des chances que ce soit la même chose sous le guider interne.

Pas encore eu l'occasion de tester!

Lien vers le commentaire
Partager sur d’autres sites

  • Avexiens

Lors de ma dernière prise la monture a fait correctement le retournement. Vers minuit 30 pour continuer à suivre M65 puis vers 2h du mat je suis allé sur m64 et les prises ont continué. Mais pourquoi pas ajouter un settle après la fin du calibrage...

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...

Information importante

Conditions générales